Debian5(lenny)升级至Deiban6(squeeze)

VPS上只有Debian5的模板,需要升级为Debian6.

1.修改source.list为Debian6

# vi /etc/apt/sources.list
deb http://ftp.us.debian.org/debian/ squeeze main
deb-src http://ftp.us.debian.org/debian/ squeeze main
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
deb http://volatile.debian.org/debian-volatile squeeze/volatile main
deb-src http://volatile.debian.org/debian-volatile squeeze/volatile main

注意:volatile.debian.org已经不在官方源了,注意

2.执行升级命令

首先清除原有信息:

#apt-get clean
#apt-get update
#apt-get install apt dpkg aptitude
#apt-get dist-upgrade

3.重启即可

Leave a Reply

Your email address will not be published. Required fields are marked *